Social post and landing page issues

Incident Report for Constant Contact

Resolved

Issues loading Social pages and Landing pages has been resolved.
Posted Sep 24, 2025 - 14:45 EDT

Investigating

Some customers may currently be encountering difficulties loading Social pages and Landing pages. We are actively working to resolve this issue.
Posted Sep 24, 2025 - 13:15 EDT
This incident affected: Landing Pages and Social Media.