Slowness when navigating website and delays when sending campaigns

Incident Report for Constant Contact

Resolved

Mail has started to send and stability has been restored when navigating Constant Contact
Posted 1 year ago. Mar 07, 2024 - 12:20 EST

Investigating

At this time, customers may experience slowness within the product as well as campaign sending delays. We are working to resolve these issues as soon as possible.
Posted 1 year ago. Mar 07, 2024 - 11:48 EST
This incident affected: Email Delivery (Email Campaigns) and Login.