Sign-up Landing Pages Temporarily Disabled

Incident Report for Constant Contact

Resolved

Landing pages are enabled.
Posted 8 months ago. Aug 16, 2024 - 13:15 EDT

Update

We are continuing to investigate this issue.
Posted 8 months ago. Aug 16, 2024 - 10:38 EDT

Investigating

We have temporarily disabled Sign-up Landing Pages while we resolve a system issue. We're working to resolve this as quickly as possible.
Posted 8 months ago. Aug 16, 2024 - 10:37 EDT
This incident affected: Landing Pages.