Issues Logging in and Loading Accounts

Incident Report for Constant Contact

Resolved

Login functionality has been restored. Page load times within the product have also been restored.
Posted 1 month ago. Mar 04, 2025 - 12:43 EST

Update

We are continuing to investigate this issue.
Posted 1 month ago. Mar 04, 2025 - 12:42 EST

Investigating

Some of our customers are experiencing slow load times while navigating through the product. We are working to resolve this as quickly as possible.
Posted 1 month ago. Mar 04, 2025 - 10:09 EST
This incident affected: Login.