Slowness navigating the website and delays sending campaigns
Incident Report for Constant Contact
Resolved
The incident has been resolved.
Posted Mar 06, 2024 - 15:07 EST
Investigating
At this time, customers may experience slowness within the product, as well as campaign sending delays. We are working to resolve these issues as soon as possible.
Posted Mar 06, 2024 - 11:40 EST
This incident affected: Campaign Creation (Email Campaigns, Event Campaigns, Survey Creation, Email Automation) and Email Delivery (Email Campaigns).