Slowness navigating the website, delays sending emails.

Incident Report for Constant Contact

Resolved

This incident has been resolved.
Posted 1 year ago. Feb 01, 2024 - 17:22 EST

Investigating

Some of our customers are experiencing slowness while working in their accounts, and delays sending emails. We are working to resolve this as quickly as possible.
Posted 1 year ago. Feb 01, 2024 - 11:26 EST
This incident affected: Campaign Creation (Email Campaigns, Event Campaigns, Survey Creation, Email Automation), Email Delivery (Email Campaigns, Email Automation), and Contacts (Contact Management, Segments).