Issues Viewing Reporting

Incident Report for Constant Contact

Resolved

The issues accessing campaign reporting have been resolved.
Posted Oct 02, 2025 - 11:00 EDT

Investigating

We are aware of an issue preventing some customers from viewing drill-down reports. We are actively working to resolve the issue.
Posted Oct 02, 2025 - 09:30 EDT
This incident affected: Reporting.