Issues Logging in and Loading Accounts

Incident Report for Constant Contact

Resolved

The root cause has been identified and repaired. All delayed mail has been processed, and login function has been restored.
Posted May 05, 2025 - 12:44 EDT

Investigating

We are currently experiencing issues affecting customers logging into accounts, navigating the site is slower than expected and sending email campaigns may be delayed. We appreciate your patience as we work to resolve this issue.
Posted May 05, 2025 - 09:04 EDT
This incident affected: Login.