Campaign Sending Delays
Incident Report for Constant Contact
Resolved
Mail is currently sending as expected.
Posted Oct 20, 2023 - 19:16 EDT
Update
We are continuing to investigate this issue.
Posted Oct 20, 2023 - 18:17 EDT
Investigating
At this time, customers may experience campaign sending delays. We are working to resolve these issues as soon as possible.
Posted Oct 20, 2023 - 16:29 EDT
This incident affected: Email Delivery (Email Campaigns, Email Automation) and Login.