Email Campaigns: A Service Disruption is In Effect
Incident Report for Constant Contact
Resolved
This incident has been resolved.
Posted Oct 27, 2022 - 13:40 EDT
Investigating
Some customers are experiencing an error when trying to save and edit email campaigns. We are currently working on resolving this as quickly as possible.
Posted Oct 27, 2022 - 11:02 EDT
This incident affected: Campaign Creation (Email Campaigns).